Commit 2f7a8d72 authored by J. Fernando Sánchez's avatar J. Fernando Sánchez
Browse files

Fixed setup.py and pip

parent 2b688385
include requirements.txt
include README.md
include senpy/context.jsonld
......@@ -18,8 +18,8 @@
Sentiment analysis server in Python
"""
VERSION = "0.2.7"
import extensions
import blueprints
import plugins
__version__ = "0.2.8"
from setuptools import setup
import senpy
from pip.req import parse_requirements
# parse_requirements() returns generator of pip.req.InstallRequirement objects
install_reqs = parse_requirements("requirements.txt")
# reqs is a list of requirement
# e.g. ['django==1.5.1', 'mezzanine==1.4.6']
reqs = [str(ir.req) for ir in install_reqs]
VERSION = "0.2.8"
print(reqs)
setup(
name='senpy',
packages=['senpy'], # this must be the same as the name above
version=senpy.VERSION,
version=VERSION,
description='''
A sentiment analysis server implementation. Designed to be \
extendable, so new algorithms and sources can be used.
......@@ -12,7 +23,9 @@ extendable, so new algorithms and sources can be used.
author='J. Fernando Sanchez',
author_email='balkian@gmail.com',
url='https://github.com/balkian/senpy', # use the URL to the github repo
download_url='https://github.com/balkian/senpy/archive/{}.tar.gz'.format(senpy.VERSION),
download_url='https://github.com/balkian/senpy/archive/{}.tar.gz'.format(VERSION),
keywords=['eurosentiment', 'sentiment', 'emotions', 'nif'], # arbitrary keywords
classifiers=[],
install_requires=reqs,
include_package_data = True,
)
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment